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Remark Office OMR  

Demo Tutorial 

Grading Tests 

Tutorial Overview 
Thank you for downloading a demo version of Remark Office OMR. In order to allow you to sample 

the functionality in the software, we have included this tutorial. The tutorial works with pre-supplied 

sample image files so that you can walk through the various steps of using the software. The sample 

files used in this tutorial are located in your My Documents folder in a subfolder called Remark Office 

OMR\Tutorials. This tutorial outlines how to create a form template for a basic test form. It also details 

how to process forms, correct the output and run a report. 

Note: If you plan to use Remark Office OMR to collect data from survey forms, there is 
a separate tutorial accessible from the Help menu that focuses on surveys. 

Important Note: The tutorials provided with the software work with image files that are included 

when you install the Remark Office OMR demo. In reality, the software can read pages directly from a 

scanner, or import scanned image files. Even though you are importing image files, the steps you are 

taking are very similar to scanning directly in the software. If you process your own forms directly with 

a scanner, you choose the options to scan instead of read from images within the software. The 

tutorial still gives you a good overview of how the software works in order to prepare you for using 

your own forms and scanner. 

There are some basic concepts to review before you get started with the tutorial. Please note that 

there are several ways to access basic software functions. Three of the most common methods 

include: 

• Getting Started Task Pane: The task pane on the left side of each Remark Office OMR 

window can be used to access the most common functions in the software. The task pane 

automatically updates based on the functions you perform. You can show or hide the task 

pane by selecting the View menu and then clicking Task Pane. 

• Toolbar: The toolbar is the series of icons across the top of each Remark Office OMR 

window. These icons represent shortcuts for common functions within the software. Hover 

your mouse over any button to see tool tip text explaining the functionality of the button. 

• Menus: The pull-down menus have all of the functions available within the software. Many of 

these functions can also be found in the toolbar and task pane. 

It is up to you to decide how you wish to access software functions. We will work with all three 

methods to allow you an understanding of each.  
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Before we begin, we need to touch briefly on some important concepts that may be new to you. Just 

take in the big picture for now; details will be built as these concepts are used in the lesson. 

Form Template Overview 
The following concepts are important to understand when performing this tutorial. Here is a quick 

overview to help you get started: 

What is a Form Template File?   

The first thing you do in Remark Office OMR is create form templates for the forms you wish to 

process in the software. A form template file contains the information needed to instruct Remark 

Office OMR about each form. The form template conveys the location of the information on the 

pages (e.g. the bubbles the respondents will darken) and the specifics of the data you require. The 

form template defines the backend database you will use for storage of the processed data. You will 

create a form template for each form that you wish to process using the software.  

How are Form Templates Created? 

Form templates are created by scanning an unmarked copy of the form (or importing a scanned 

image) to create an equivalent image in the Remark Office OMR Template Editor. You then use the 

mouse to drag boxes (called regions) around the marks (e.g. bubbles) and other areas you want to 

have recognized on your form. These regions tell the software where each piece of information you 

want to capture is located on the page and other pertinent information about the form. They also tell 

the software what type of data you need the software to output from each area.  

You are now ready to get started with the tutorial.  

The 30 Question Exam Answer Sheet  
This tutorial quickly teaches you how to use the basic software functions and how to easily navigate 

the software’s user interface. You create a form template for a 30-question exam or test. This exam 

form includes bubbles for students to enter their student ID and 30 multiple choice questions with the 

answer choices of A-E. The exam answer sheet would be paired with a question sheet or booklet when 

students take the test.  

You will perform the following steps in this tutorial: 

• Create the exam form template 

• Process completed exam forms 

• Review and correct the data output 

• Grade and analyze the exam data with Remark Quick Stats® 

The next page shows an image of the exam so you can get an idea of the type of form being used in 

this demonstration. The exam form was created in Microsoft Word. You can also find a copy of this 

form in Documents\Remark Office OMR\Tutorials\Demo Tutorial 1. 
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Creating the Exam Form Template 
The first step in this process is to create a form template outlining the areas on the form that you 

want the software to recognize. 

 

To begin setting up the exam form template 

1. If not already running, start Remark Office OMR (Start|Programs|Remark Office OMR 

Demo|Remark Office OMR Data Center). 

2. Begin a new form template. Select the File menu and then click New form template. 

Alternatively, in the left-hand panel, known as the Task Pane, select New. Any of these actions 

opens a second window containing the Remark Office OMR Template Editor.  

Tip: If you use File|New Form Template or the New link in the Task Pane, the 
Template Editor opens with the new form template window already opened for you.  

3. [Optional] If the Template Editor opens but you do not see the Properties – Form Template 

(New) window, select the File menu and then click New Form Template. Alternatively, select the 

New link in the task pane.  

The Properties – Form Template (New) window opens. This window is where you describe your 

form to Remark Office OMR. You will do this by 

entering basic information about your form, 

including the form template description, page size 

and page orientation.  

1. Enter 30 Question Exam in the Description 

box.  

2. Locate the Page size area where you can tell 

the software the size paper your form uses. 

Select US Letter from the drop-down list.  

3. Locate the Page orientation area and select 

Portrait. 

4. Click the Capture Image button to continue.  

The Create Page Elements window appears. The Create Page Elements window allows you to either 

acquire an image of your form from your scanner, or acquire an image of your form from an existing 

image file. Each page in a form template is created using an image of the appropriate page in your 

form. The image allows you to see the form so that you can easily teach Remark Office OMR how to 

read it.  

 

To obtain a form template image 

As previously mentioned, there are two ways to acquire an image for a form template page. Images 

can be acquired by scanning to create a new image file or by opening an existing image file. We are 

acquiring our image from a pre-scanned image file stored on your computer.  

 

1. Click the button for Read Images. 

2. Click the Browse button. The Select Image File window opens. 
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3. Select the Remark Office OMR Demo 

Tutorial 1 – Sample Exam.pdf file from 

the Tutorial 1 folder of your Remark Office 

OMR installation directory (e.g. 

Documents\Remark Office 

OMR\Tutorials\Demo Tutorial 1) and then 

click the Open button. 

Once an image is acquired by opening an 

existing image file, the Template Editor 

displays a thumbnail of the image for your 

approval. 

4. When a thumbnail image of your form appears, click the OK button to accept the image.  

Once the thumbnail image is accepted, the Template Editor opens the new form template where you 

can begin defining the regions. You see a tree view (item list) on the left and an image representation 

of your form on the right.   

 

To define form template regions   

The purpose behind making a form template is to tell the software where to locate the information on 

your specific form and how to understand your specific data requirements. The intent of this sample 

form is to expose you to a variety of region types. The following table lists the seven regions on the 

Restaurant Evaluation form and their corresponding region types: 

 

Area on Form Corresponding Region Type 

Student ID OMR (Grid) 

Questions 1-15 OMR (Multiple) 

Questions 16-30 OMR (Multiple) 

 

To define Student ID as an OMR region 

The Student ID region needs to capture the 10 digits as one piece of information (e.g. 1234567890). 

We will employ a Grid OMR region to define the bubbles on the form. A Grid OMR region outputs a 

single piece of data regardless of the number of rows and columns included in the region. This type 

of region is used for items such as dates, ID numbers, social security numbers, etc.  

 

1. Select the Page 1 node in the tree view menu, click Insert and then 

click OMR Region After Selected Page, or click the OMR toolbar 

button. Draw the OMR region box around the entire group of bubbles. 

Place the cursor at the top left of the bubble group in the student ID, 

then press and hold the left mouse button while dragging the 

rectangle to the bottom right corner, capturing all 10 rows and 10 

columns of bubbles in the region. When creating OMR regions, you 

want to leave a small buffer space between the region box and the 



6 

 

bubbles (about 1/8 inch). (Do not worry if your box is not perfect; you can adjust it when you 

finish creating the region.) 

2. After positioning the box, release the mouse button, and the Properties - OMR Region window 

appears. The Properties - OMR Region window allows you to enter information that will define 

the OMR region and the data it produces, including:  

• Region Definition (the area containing Region name, the type of OMR region or OMR type 

and the Data type).  

• Region Layout (the area detailing how many Rows and Columns of marks are contained in 

the region and their orientation).  

• Response Choices (the Labels you want to see as your data). 

3. In Region Definition area, enter Student ID in the Region name box. This name is used to 

identify the region in the data set. 

4. Select Grid for the OMR type. A grid region 

allows the respondent to choose several response 

bubbles to make up one single response (a 

student id in this case). 

5. Select Numeric for the Data type. We are 

capturing a 10-digit number.  

6. In the Region Layout area, select Column for the 

Region orientation. Each column in this region 

represents one digit of the student ID. 

7. In the Columns in region box, ensure that 10 

was entered for the Columns in the region and 

10 in the Rows in region box.  

8. Enter the appropriate Labels in Response 

Choices. For the Labels area, click the down 

arrow for Possible label scales and choose the 

scale 0 to 9 from the list of choices. This range represents the response choices for bubbles in all 

ten columns, moving from top to bottom. The numbers fill the Labels grid automatically. The 

Labels represent the actual data that will be returned from the processed forms when filled in by 

the respondent, and the Grid region will return all selections to make a ten-digit number.  

9. We want to use the student ID to identify 

our students. Click the Analysis… button. 

10. Mark the checkbox for Designate as a 

respondent ID during analysis (note that 

grading and tabulating need to be turned 

off to enable this option). 

11. Click the OK button to close the Analysis 

options. 

• Note: Don’t worry about setting up 

your answer key now; we will scan it 

later with our filled in tests. 

12. Click the OK button to return to the main Template Editor window. 
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You now see a green box around the Student ID region in the form area, identifying it as an OMR 

region. You will also see that Student ID has been added to the tree view. 

To define questions 1-15 as an OMR region 

There are 30 multiple-choice questions on the exam, divided into two sections. You can create a 

region around the first 15 questions and then copy it to the second 15 questions.  

 

1. Highlight the Student ID node in the tree view, if not already highlighted.  

2. Click the OMR toolbar button. Alternatively, select the Draw Regions link in the 

Task Pane and then Insert OMR Region. 

The mouse changes to a crosshair. 

3. Place the cursor at the top left of the bubble group in question 1, then press and 

hold the left mouse button while dragging the rectangle to the bottom right 

corner of question 15, capturing all 15 rows and five columns of bubbles in the 

region.  

4. After positioning the box, release the mouse button. The Properties - OMR 

Region window appears.  

5. In the Region Definition area, enter Question in the box titled Region name. 

This name is used to identify the region in the data set. The additional questions 

within the region will be number sequentially 

(Question1-Question15). 

6. For the OMR Type, select Multiple. The Multiple 

region designation is used for typical multiple 

choice style questions.  

7. For the Data type, select Textual. This region 

contains a textual scale of agreement statements, 

so textual data is appropriate.  

8. In the Region Layout area to the right, if it is not 

already selected, choose Row for Region 

orientation. Region orientation lets Remark Office 

OMR know how the region is structured on the 

form. For this question, each row represents one 

question. 

9. Ensure that 5 was entered in the Columns in the region box and 15 in the Rows in the region 

box. The region size lets Remark Office OMR know how many rows and columns of marks are in 

the region and the software tries to figure this out for you. 

10. Enter the appropriate Labels in Response Choices. For the Labels area, click the down arrow for 

Possible label scales and choose the scale A-E (5) from the list of choices. This range represents 

the response choices for the bubbles in all five columns, moving from left to right. The entries will 

fill the Labels grid automatically. The Labels represent the response choices for each bubble. You 

will notice that as you type Labels, or when they auto-fill, numbers automatically fill the Values 

column to the right. While the Labels represent the actual data you will see returned from the 

processed forms, the Values represent the information Remark Office OMR uses to perform any 

statistical analysis (such as calculating means).    

11. Click the OK button to return to the main Template Editor window.  
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You now see a green box around the first 15 questions in the form area, identifying it as an OMR 

region. You also see that Question has been added to the tree view. 

 

To define questions 16-30 as an OMR region 

The easiest way to capture the second set of multiple-choice questions is to copy the Question region 

since it has everything defined that you need. 

 

1. Highlight the Question node in the tree 

view, if not already highlighted.  

2. Select the Edit menu and click Copy (or 

press Ctrl+C on your keyboard). 

3. Select the Edit menu and click Paste (or 

press Ctrl+V on your keyboard). 

4. The region is copied next to the original 

region and is red. Use your mouse to click 

and drag the region over questions 16-30. 

The region turns green when you have it 

properly placed. All of the settings are carried over so there is nothing else you need to define. 

 

To save the tutorial form template 

We have finished creating all of the regions in our form template and need to save the form template 

as a file we can use to process completed forms. 

 

1. Select the File menu and then click Save. Alternatively, select the Save link in the Task Pane. Make 

note of where you save the form template file (we suggest My Documents\Remark Office 

OMR\Tutorials\Demo Tutorial 1).  

2. In the File name box, type Demo Tutorial 1 and then click the Save button (the .omr extension is 

added automatically for you). 

Note: If someone has already completed the tutorial with this file name, you may 
modify the file name.  

You have now created the Tutorial form template. Close the Template Editor by selecting the File 

menu and then clicking Exit. Alternatively, you may also simply click the X in the upper right-hand 

corner of the Template Editor window. You may now move on to processing the filled in exams. 
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Processing the Completed Exams 
Now that you have created the form template for the exam, you are ready to begin processing the 

completed forms using the supplied image files. For the purposes of this tutorial, we assume that the 

teacher administered the tests to the students and scanned the exams into a PDF file. 

 

To open the exam form template 

1. If not already running, start the Remark Office OMR Data Center (Start|Programs|Remark Office 

OMR Demo|Remark Office OMR Data Center). When the Data Center opens, it displays a blank 

spreadsheet-style data grid. The Data Center offers a Task Pane on the left containing the most 

commonly requested actions.  

2. Select the File menu and then click Open Form Template. Alternatively, select the Open link in 

the Task Pane. You must open a form template in order to process forms. 

3. Select the Demo Tutorial 1.omr file (the file you created in the previous section of this tutorial) 

and then click the Open button. Alternatively, we have provided a sample file in 

Documents\Remark Office OMR\Tutorials\Demo Tutorial 1\Remark Office OMR Demo Tutorial 

1.omr.  

When the exam tutorial form template opens, its name appears on the title bar at the top of the 

screen and you see the region names you specified as your column headers in the data grid. Each 

column in the grid corresponds with one variable or question in the form template, as the column 

headers indicate. The data grid fills row by row as your completed forms are processed. Each grid row 

contains information from one processed form regardless of the number of pages the form contains. 

 

To read forms from image files 

The Read window is used to process completed forms and produce data. The Read window has 

several steps to help customize the reading process. This tutorial will focus on the basic functions. As 

mentioned previously, we will be reading pre-scanned image files. 

 

1. Select the Tools menu and then click Read. Alternatively, select the Read link in the Task Pane. 

2. The Office Read window appears.  

3. Select the button for Read Images. 

4. Click the Next button to continue. 

The Image Selection window appears to enable you to view 

and select the images you want to process. 

5. Navigate to the Tutorial 1 folder of your Remark Office 

OMR Demo installation (e.g. Documents\Remark Office 

OMR\Tutorials\Demo Tutorial 1).  

6. Navigate to the Images for Processing folder.  

7. Select the file called Demo Tutorial 1 – Completed 

Exams.pdf by either double clicking it or selecting it 

and clicking the button for Add Selected, which moves 
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the file into the Image List window on the right. This multi-page PDF file contains 10 completed 

exams, including an answer key that we bubbled in.  

8. Click the Next button to continue. 

The Review Exceptions window appears. This window allows you to configure options for reviewing 

exception cases such as blank and multiple responses. We will not be using this feature in this tutorial.  

9. If the Enable Review Exceptions button is marked, click it to deselect this option. We will not be 

reviewing exceptions at this time. 

10. Click the Read button to begin reading image files. 

As each image is processed, you see a row added to the data grid. Once all the forms are processed 

you are ready to review and clean the data. 

Reviewing and Correcting the Data 
After the forms are processed, 10 rows of data are displayed in the data grid. Each row represents the 

responses collected from one of the forms. The first row is our answer key. You are now ready to 

inspect the data for missing or unrecognized responses in order to prepare for either analysis or 

export.   

Remark Office OMR informs you of unrecognized or questionable responses by color-coding each 

appropriate data grid cell and including a short descriptive word describing the exception (e.g. 

BLANK). The software then assists you to correct exception cases or problems by allowing you to see 

what was entered on the actual form. The stored images for each processed form are available to 

show you respondents’ answer choices. 

For this tutorial, we are going to run Review Exceptions, which provides an automated way to search 

through the data for exceptions and then correct them. 

 

To run Review Exceptions 

1. Select the Tools menu and then click Review Exceptions. Alternatively, select the Review 

Exceptions link in the Task Pane. 

2. Once you access Review Exceptions, use the task pane to select the exception cases you would 

like to review: Blank responses, Multiple Responses, Recognition Errors, Image Regions, Database 

Lookup Regions, Barcode Regions, OCR Regions, Repeated Rank Responses or Required Items. 

You can also choose whether to search by rows or columns in the data grid. In our case, we will 

be reviewing blank and multiple responses. 

3. Click the NEXT button at the top of the data grid to start the review process.  

The Data Center searches the data for the specified exception cases. When a selected exception case 

is found, it appears in the data header bar at the top of the data grid. The bar is color coded to match 

the exception type (e.g. yellow for a BLANK response). Use this window to make changes. You can use 

the drop-down list if applicable, or type a response. Note if there is a list of answer choices defined, as 

you begin typing, Remark Office OMR will attempt to auto-fill your answer based on your possible 

answer choices.  
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3. The first piece of flagged data is a blank 

response in row three for question 19. If you look 

at the Image Viewer, you see that the 

respondent truly did leave this question blank. 

Therefore, no changes are necessary. Press Enter 

or click the NEXT button to continue. 

4. The next exception is a multiple response in row 

four for question 24. Look at the Image Viewer to 

see the intended response. In this case, it looks 

like the respondent changed his response from 

D to A by crossing out the original mark and 

filling in a second bubble. We will assume that A 

is the intended response. Select A from the 

drop-down list (or type “A”). 

5. Press Enter or click the NEXT button to continue. 

6. The next piece of flagged data is a multiple 

response in row ten for question 5. It appears 

that the respondent changed his response from 

C to E by crossing out the original mark and 

filling in a second bubble. We will assume that E 

is the intended response. Select E from the drop-

down list (or type “E”). 

7. Press the Enter key or click the NEXT button. 

There are no more exception cases in the data.  

8. When prompted, click the Save Changes button 

to save your changes. 

Your data is now ready to be saved and analyzed. 

The demo version of Remark Office OMR does not allow data to be saved. In the full version of the 

product, you can save your data to many file formats, including Microsoft SQL Server, Access, Excel, 

SPSS®, CSV, Oracle, and others. We will continue on to analysis of the data. 

Grading the Exam Data 
Remark Office OMR provides statistical analysis functionality for grading data from your forms. The 

Quick Grade feature is one such facility and provides you with a choice of standard reports based on 

your data. It uses the first row of data as the answer key. 

• Note: There is an Advanced Grade feature that allows for full customization of the grading 

process, including changing point values, adding extra credit, setting up learning objectives, 

applying benchmarks, using multiple test versions, and more. 

 

To grade the exam data 

1. Select the Tools menu, then click Analysis and then click Quick Grade. Alternatively, click the 

Analysis tab and then select the Quick Grade link in the Task Pane. 

The Remark Quick Stats window appears. 
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Once Remark Quick Stats opens, you have access to a variety of grade reports. You can report on the 

test itself, the class or individual students. For this tutorial, we will look at the Student Statistics, 

Student Response and Student Grade Reports. 

To run the Student Statistics Report 

1. By default, the Student Statistics report displays automatically. If you are not seeing this report, 

select the Student Statistics link in the list of reports under Class and Student Reports.  

The Student Statistics Report displays 

the grades for the entire class. Each 

student can optionally be identified by 

an Analysis Respondent ID region 

(chosen in the form template or 

Advanced Grade) if desired. In this 

tutorial, we designated the Student ID 

OMR Grid region as an Analysis 

Respondent ID. This report provides a 

nice overview of how your class is 

performing.  

Next, we will look at the Student 

Grade Report. 

 

To run the Student Grade Report 

1. In the Task Pane under Class and Student Reports, select the 

Student Grade link.  

2. Select one or more students from the Respondents list and 

click the Add button to move them to the Selected 

respondents list. Alternatively, click the Add All button to move 

all students over. 

3. Click the Run Report button; the report displays on the right. 

The Student Grade Report shows an individual report of each 

student’s grades. You can show the correct and incorrect responses, 

as well as an image of the actual test as it was scanned. If defined, 

learning objectives are tracked, as well as subjective and extra credit 

points.  

There are other reports available that we encourage you to view by 

clicking their links in the Task Pane. Note that you can experiment with the report options in the 

Report Style pane. In the full version of the software, you can export the reports to several formats, 

including PDF, Excel, RTF, and TIF. In addition, there is a Report Batch option that allows you to filter 

the data on up to three items in your data set and then automatically generate, print, and/or export 

the resulting reports. You can also export grades to various gradebook programs. 
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Tutorial Summary  
This tutorial illustrated the basics of using the software, including:  

• Creating a form template 

o OMR grid regions 

o OMR multiple choice regions 

• Processing forms 

• Using Review Exceptions to clean data 

• Grading exams with Quick Grade 

o Student Statistics Report 

o Student Grade Report 

 

You have completed the Remark Office OMR tutorial. We hope that this tutorial has given you an 

overview of how the software works. The full version of Remark Office OMR has many more features 

to help you grade all different kinds of tests. Please note that the demo you are using can also be 

used with your own forms. Please visit our website for more product information or to purchase. For a 

full functioning trial of the software, please contact our sales department. We are always happy to 

look at the forms you want to process and answering any questions you may have. 
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